サポートするアプリケーションの種類

 

TestComplete 12.60 でサポートするアプリケーション

開発ツールに依存しません。 TestComplete は、幅広いアプリケーションでソフトウェアのテストを自動化します。任意の言語で開発された 32ビット、64ビット Windows、.NET、Java、Web アプリケーションでのユーザーアクションをシミュレートできます。

広範囲なアプリケーションをサポート

他のテスティング ツールと異なり、TestComplete は、特定のコンパイラーでのみ作成されたアプリケーションのテストに制限されることはありません。各種開発ツールおよびプログラミング言語で作成されたアプリケーションが同等に動作します。以下は、TestComplete がサポートする主なソフトウェア プラットフォームとアプリケーションの種類の一覧です:

サポートする環境の最新情報は、開発元のサイトをご参照ください。

サポートするサードパーティ製コントロールは、開発元のサイトをご参照ください。


Desktop

すべての既存の .NET コンパイラー。例えば:
  • Microsoft: Visual C#, Visual Basic .NET および Visual C++ .NET (マネージド コード) ver. 7.0 - 15.0, JScript .NET (Visual Studio ver. 8.0 only with Service Pack 1 installed)

  • Microsoft 以外: Borland C#Builder, Borland Delphi for .NET (Delphi 8, Delphi 2005 および 2006), CodeGear Delphi 2007 for .NET, Sybase PowerBuilder .NET 12, Python .NET, Cobol .NET, およびその他

TestComplete は、 .NET Framework ver. 2.0 - 4.7.1 用に作成されたアプリケーションをサポートします。

Microsoft Visual C++ 6.0, Visual C++ (アンマネージド コード) ver. 7.0 - 15.0 (Visual Studio ver. 8.0 only with Service Pack 1 installed)
Intel C++ Compiler 11.0.066
64-bit .NET, Delphi, Java, Windows および Qt アプリケーション ( Testing 64-bit Applications を参照)
Microsoft Visual Basic 6.0
Borland Delphi 7.0, Delphi 2005 および 2006, CodeGear Delphi 2007 および 2009, Embarcadero Delphi 2010, XE – XE8, 10, 10.1(Update1 および Update2)
Borland C++Builder 6.0, C++Builder 2006, CodeGear C++Builder 2007 および 2009, Embarcadero C++Builder 2010, XE – XE8, 10, 10.1(Update1 および Update2)

注意: TestComplete は、VCL および CLX またはサードパーティの VCL- および CLX-ベース コントロールを使用している Delphi および C++Builder アプリケーションのみサポートします。
TestComplete は、グラフィックとしてアプリケーション コントロールを描画するクロスプラットフォーム GUI フレームワークを使用してビルドしたアプリケーションをサポートしません (たとえば、Embarcadero FireMonkey)。
AWT, SWT または Swing ライブラリーを使用する Java 5 - 10 アプリケーション。32-bit および 64-bit Java バージョンの両方をサポートします。
JavaFX SDK ver. 2.2.7 - 2.2.45, 8, 9, 10.
Qt ver. 5.0 - 5.9 by Digia, Qt (32-bit および 64-bit の両方の Qt アプリケーションをサポート)。以前のバージョンのサポートのために特定のモジュールを下記のサイトからダウンロードできます:

http://support.smartbear.com/downloads/testcomplete/qt-modules/

Oracle Forms Builder 11g and 12c
Sybase PowerBuilder 12.0, 12.5, 12.5.2 および 12.6
Microsoft Visual FoxPro 7.0 およびそれ以降
Microsoft Office Access 2003 および 2007
Microsoft Office InfoPath 2003 および 2007

 

Web

以下のブラウザーで実行する Web アプリケーション:

 Microsoft Edge (32-bit および 64-bit バージョンの両方)。

 Microsoft Internet Explorer 10 - 11 (32-bit および 64-bit バージョンの両方)。

注意: Internet Explorer 10 および 11 の Modern UI (Metro) バージョンは、現在サポートされていません。

 Mozilla Firefox 52, 60 - 62 (32 および 64 bit の両方のエディション)

 Google Chrome 69 (32 および 64 bit の両方のエディション)

注意:

TestComplete 12.42 よりも以前のバージョンの場合、Chrome 69 でWeb アプリケーションをテストするには、TestComplete 12.60 にアップグレードしなければなりません。

それ以降の Google Chrome のバージョンを使用する場合、利用可能なパッチがあるかチェックしてください。

Modern UI (Metro) モードで実行している Chrome は、現在サポートされていません。

組み込み Web ブラウザー

  • 組み込み Microsoft WebBrowser コントロールを使用するアプリケーション。

  • Chromium Embedded Framework (CEF) version 3.3282.1741 またはそれ以前を使用する .NET, Java およびネイティブ アプリケーション (C++, Delphi およびその他)。

  • Electron version 1.8.2, 2.0.2 で作成されたアプリケーション (ユーザーインターフェイスが Web ページとして実装されるため、テストには、TestComplete Web モジュール ライセンスが必要となります。TestComplete Desktop モジュールのライセンスは必要ではございません。詳細はこちら)。

注意: Firefox および Chrome の新バージョンは頻繁にリリースされます。TestComplete のメインメニューから [Help | Check for Updates] を選択し、アップデートが利用可能かどうかを確認できます。[Check for update] オプションが有効な場合、TestComplete は自動的にスタートアップで最新のブラウザのアップデートをチェックします。"Yes, I want to download and install this update now" をクリックするとアップデートをインストールします。

また、新しいバージョンの Firefox および Chrome 用のアップデートは、手動で下記のサイトからダウンロードできます:

Web アプリケーション フレームワーク
AngularJS
ASP.NET (including Web Forms, Web Pages, および MVC)
Backbone.js
Bootstrap 3.3.4 および 3.3.5
Google Web Toolkit (GWT) 2.0 - 2.4, 2.5.1, 2.6.0,  2.6.1, 2.7.0
jQuery UI 1.8.13 - 1.8.20, 1.9.2, 1.10.2 - 1.10.4, 1.11.1, 1.11.2, and 1.11.4
jQuery Mobile 1.4.2, 1.4.3, 1.4.4, 1.4.5
MooTools 1.4.0.1, 1.5.1, 1.5.2, 1.6.0
React
Ruby on Rails
Sencha Ext JS 4.1.1a, 4.2.x, 5.0.x, 5.1.x, 6.0.0, 6.0.1, 6.0.2
Yahoo! UI 2.9.0, 3.4.1 - 3.18.1
リッチ インターネット アプリケーション (RIA)フレームワーク
Adobe Flash 9.0 - 17.0
Adobe Flex 3.3 - 4.6 SDK
Apache Flex 4.9 - 4.14 SDK
Adobe AIR 2, 3 および 17 SDK
Microsoft Silverlight 4 および 5
以下の仕様に準拠した Web サービス:
  • WS-I Basic Profile 1.1
  • SOAP 1.1 and 1.2 (SOAP over HTTP)
  • WSDL 1.1
次のいずれかのビンディング タイプを使用する WCF web サービス:
  • BasicHttpBinding
  • WSHttpBinding

 

Mobile

Android 4.0.1 - 4.4.x, 5.0 - 5.1.1, 6.0, 7.0 - 7.1.1, 8.0-8.1 (API Level 15-19, 21-27)

下記のデバイスで実行している iOS 9.x, 10.0 - 10.3.2, 11.0 - 11.4:

  • iPhone 5, 5S, 6, 6 plus, 6S, 6S plus, SE, 7, 7 plus, 8, 8 plus, X
  • iPad 4
  • iPad Air, Air 2
  • iPad mini 1 - 4
  • 12.9-inch iPad Pro
  • iPod touch 5

 

サポートする環境の最新情報は、開発元のサイトをご参照ください。

サポートするサードパーティ製コントロールは、開発元のサイトをご参照ください。

ページ トップに戻る